Cotações do Google Finance no Excel

Para obter cotações do Google Finance na tabela de Excel do Investindo.org, faça o seguinte:

1 – Crie uma tabela nova no Google Spreadsheets, na coluna A coloque os códigos, e na coluna B a fórmula =googlefinance(A1;”price”):

2 – Vá em Arquivo > Publicar na Web

3 – Selecione “Valores separados por vírgula (.csv)” e cheque que “Republicar automaticamente quando….” esteja selecionado. Em seguida, clique em Publicar:

4 – Copie o link que apareceu.

5 – Abra a tabela de Excel e crie uma planilha em branco com o nome ‘Cotações’.

6 – Vá em Dados > Obter dados de Arquivos > De text/Csv

7 – Uma janela de procura de arquivos irá abrir, cole o endereço do google como se fosse o nome do arquivo e clique em abrir.

8 – Confira o layout para ver se está correto e clique em “carregar”:

9- O Excel irá carregar os dados, mude a coluna de preço para aparecer como R$.

10- Depois é só usar a fórmula PROCV na planilha ‘Custódia – Ações’ ou ‘Custódia – FII’ para obter o valor da cotação.

=PROCV(A3;Cotações!A:B;2;FALSO)

10- O google atualiza as cotações na sua tabela diariamente e o Excel irá atualizar automaticamente.

Compartilhe este artigo:

TwitterFacebookGoogle+BufferPin It