INVE$TINDO

Aprenda a investir de forma simples e rápida!

Cotações do Google Finance no Excel

Para obter cotações do Google Finance em uma tabela de Excel, faça o seguinte:

  1. Crie uma tabela nova no Google Spreadsheets, na coluna A coloque os códigos, e na coluna B a fórmula =googlefinance(A1;”price”):

Cotações da Bolsa no Excel

  1. Vá em Arquivo > Publicar na Web
  2. Selecione “Valores separados por vírgula (.csv)” e cheque que “Republicar automaticamente quando….” esteja selecionado. Em seguida, clique em Publicar:

Cotações da Bolsa no Excel

  1. Copie o link que apareceu.
  2. Abra a tabela de Excel e crie uma planilha em branco.
  3. Vá em Dados > Obter dados de Arquivos > De text/Csv:

Cotações da Bolsa no Excel

  1. Uma janela de procura de arquivos irá abrir, cole o endereço do google como se fosse o nome do arquivo e clique em abrir.
  2. Confira o layout para ver se está correto e clique em “carregar”:

Cotações da Bolsa no Excel

  1. O Excel irá carregar os dados, mude a coluna de preço para aparecer como R$.

Cotações da Bolsa no Excel

  1. Depois é só usar a fórmula PROCV na planilha onde deseja ter as cotações:
=PROCV(A3;Cotaço~es!A:B;2;FALSO)=PROCV(A3;Cotações!A:B;2;FALSO)
  1. O google atualiza as cotações na sua tabela diariamente.

Atualizando os Dados

Para atualizar as cotações, acesse o menu Dados > Atualizar Tudo.